FAQ Members Login

So confused!

Post a reply

:
In an effort to prevent automatic submissions, we require that you enter both of the words displayed into the text field underneath.
Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

If you wish to attach one or more files enter the details below.

Expand view Topic review: So confused!

Re: So confused!

Post by amjon » Mon Apr 16, 2012 05:08 am

No more blood since Saturday morning and cramps have died down. Now I just have the pain on my left side. The doctor has closed and still haven't heard back from him. :(

Re: So confused!

Post by aajatwins » Sun Apr 15, 2012 03:17 am

Could be implantation pain and "spotting". I've never experienced either of those, but some ladies will have just cramping and mild to moderate spotting when implantation occurs. I think, also, that sometimes we get a fertilized egg that is unsuccessful at implanting (for whatever reason) and it can cause those things and possibly give AF an early kick start. I hope its the first one for you :) let us know how it goes!!

So confused!

Post by amjon » Sat Apr 14, 2012 08:38 am

This cycle has me very confused. I started having a 26 day cycle last month. I saw DH Thursday-Sunday (last week) and think I was due to ovulate around Thursday-Saturday of last week. I had light OPK on Wednesday morning, then light Thursday night/Friday morning and didn't get any chances to test in between, but normally have the dark test between the two lights, so assume it was then. I had what I think was ovulation pain from Wednesday (last week) on (still have it to some degree NOW over a week later). I had a very sharp, quick (probably a second or two) pain this Thursday night. The following morning my temp was raised by .6 degrees from the previous day. (I just received the basal thermometer on this Wednesday to start temping.) It's still up, but .1 down from yesterday (took it about 40 minutes later though). I started getting cramping this morning and now I'm getting some pick when I wipe and feels like AF is here, but she's not due for at least a week. Does anyone have any idea what could be going on?

Top

cron